Votes
0
Product:
iClone 7
Version:
7.71
Status:
Released in 7.8
Issue 6659
iClone would crash while baking IBL at 4096x2048 and more...
Bugs:

So it would crash baking IBL at 4096x2048. Worse yet, the registry values OnlyShowDiffuse and OnlyShowSpecular would stuck on 1.

Most users would not know that, while any project opened after the crash would not properly render and displayed in view-port until values are set to 0 manually.

In addition, some texture would appear extremely dark (almost black) rendered in an IBL bake. I am sure that is not how it is supposed to be.

--------------------------------------------------------------------------

Suggestion:

Since the IBL bake is radically different from the normal view-port display (most of the time it is darker), it is hard to understand how to tweak the project lights, GI, shadows, Ambient for the best desired IBL baked output.

So I suggest to enable IBL bake view-mode as one of the options in Real-Time drop-down box.
I can emulate that by setting those 2 mentioned registry values to 1 and restarting iClone.
But it would be nice to have it as an option, so that users can view baked result real-time and do the necessary tweaking to the scene for the best desired baked IBL output.

See the forum post for an example: https://forum.reallusion.com/FindPost435468.aspx
OS: Windows 10
  •  9
  •  814
Submitted by4u2ges
1 2
COMMENTS (9)
4u2ges
Hi Molly,

Please note that sometimes you have to try a few times in a row for this to happen and it is only happening when Baking IBL image with size which is greater than 2048x1024.
And it is always happening at 21% progress mark. If it passes 21%, then it bakes fine. But as I said it crashes with 4096x2048 and above (sometimes from the first try and sometimes after 2 or 3 times).

I have attached the registry gathered with your utility.

Couple of notes:

1. IBL baking got some overhaul in v7.73. I noticed it is now bakes correctly without that grayish tone which hdr output had before v7.73 (or maybe even v7.72) (screenshoot1).

2. Unfortunately, it is still crashes on me when I bake at 4096x2048, leaving "OnlyShowDiffuse" and "OnlyShowSpecular" values at "1" in the registry. Though I must admit, it seems does not affect much the view-port and render anymore when iClone is restarted after the crash (guess because Baking was fixed overall removing that gray-over effect). But still I suggest to reset those values to 0 when iClone is starting!

3. A side note. I installed a Live Link Trial and have some strange registry entry (screenshot 2). I do not think it affects anything, but I believe it does not belong there.

Thanks
Attachment:
  • Compare.jpg
  • ULLP.jpg
4u2ges
Hi Molly,

I did test it and it works fine now.

Thank you!
Feedback Tracker Admin
Private Comment
Feedback Tracker Admin
Hi 4u2ges,

We've try several computer to reproduce this issue, but to no avail.Can you provide your registry to? You can use Private Comment if you want to keep it private.
We wonder If your current user registry could help us reproduce it.

Here is the description about how to get your system information file.
https://www.reallusion.com/FeedBackTracker/Home/HowToGet

Molly
Reallusion
Feedback Tracker Admin
Hi 4u2ges,

I have got it, Thank you very much.

Molly
Reallusion
4u2ges
Hi Molly,

It baked fine first time and then crashed twice in a row. So I enclosed 2 dumps for the built you provided.

https://www.dropbox.com/s/y4kvddrx7146fw2/iClone.exe.102464.zip?dl=0

Thanks
Feedback Tracker Admin
Private Comment
1 2