Votes
0
Product:
iClone 7
Version:
7.01
Status:
Released in 7.3
Issue 3539
Root motion is not exported to .fbx and so is incompatible with Unreal Engine 4
I am trying to use iClone to bring characters and animations in to Unreal Engine . Specifically, I am using CC2 to create characters, Perception Neuron Solo to record animations, and 3DXchange to convert existing animations to the iClone standard.

I have been successful in importing characters as when you export from iClone 7 there is an option to match the UE4 skeleton and this includes the root bone. I can then use existing animations which have root motion - this is great!

The problem is with exporting animations from iClone. They match the skeleton, but exclude the root bone animation track. If there was root motion in the animation file then the root bone would be directly under the hips and a red line would trace the avatar's path.

I have also tried exporting using 3DXchange. This also does not include root motion and, in addition, does not match the UE4 standard skeleton. If it were able to export root motion I would consider batch converting all of my existing animations and using the 3DXchange skeleton, but at the moment there is no benefit to that.

I've tested to see if it is my animations by importing an animation which I know to have root motion to 3DXchange and exporting it for UE4. I find that the root motion has been removed.

This seems to be a bug with the FBX export in both iClone and 3DXchange, because the functionality in iClone strongly suggests root animation. For example, the ability to "align > root". Further, the export license and ability to export for "Unreal" strongly suggests compatibility with UE4. No root motion means no compatibility.

Software details:
iClone 7
iClone 3DXchange 7 Pipeline
Character Creator 2 for iClone
CrazyTalk 8 Pipeline.

All software is updated to the most recent patch.
OS: Windows 10
Attachment:
  •  24
  •  9448
Submitted byAstonALIVE
COMMENTS (24)
HitEmUp
7.2 here and still not fixed... ahhhhh!!!
AstonALIVE
Good idea HitEmUp, but good luck getting anything from technical support. See attached for the support ticket I have had open since 31/08/2017 (which followed another opened 09/06/2017). The upload tool only allows for image formats, so sorry for that. The ticket ended with them suggesting I use the feedback tracker to contact the devs as the support team have no way to do so.

I01, the problem is not fixed yet. We have had no comment from Reallusion. 

I am getting by using my workaround at the moment, but soon I need to be producing many more animations and I need the software to be compatible with UE4. 
Attachment:
  • Reallusion_Support_Ticket_Page_1.jpg
  • Reallusion_Support_Ticket_Page_2.jpg
  • Reallusion_Support_Ticket_Page_3.jpg
  • Reallusion_Support_Ticket_Page_4.jpg
  • Reallusion_Support_Ticket_Page_5.jpg
  • Reallusion_Support_Ticket_Page_6.jpg
HitEmUp
Guys, i think they forget about this or us. We shoud all make a support ticket for that, maybe then the devs hear about this issue. Reallusion Marketing advertize that iClone is ue4 ready but it isn't when this issue is not fixed. So the devs need to know! And the support is the best way to get in conntact maybe. 
We wait to long for this small fix, we need to act. The workarounds for this bug take to much time. Reallusion need to react or simple remove the UE4 logo of their site and description. Since it is not compatible with UE4.
IO1
Hi Reallusion im thinking about upgrading to 3dx pipeline 7 can you assure me that this issue will be fixed because iclone is key part of my workflow?
AstonALIVE
I've made a YouTube tutorial which covers a simple workaround for this which should help until Reallusion make their fix. 

link: https://youtu.be/80cOPnhK-o4

Any questions let me know.

Any update would be great, Reallusion.