Votes
2
Product:
iClone 7
Version:
7.3
Status:
Assigned
Issue 5255
TOON Shader outline is broken
I say "broken" because if this is a fix, it is a disaster.

In Iclone 6 the outline feature was constant (AFAIK) in that a one pixel outline (outline width 1) remained one pixel no matter what the scale of the final render.

In 7.3 it appears that the outline is not only thinker, but that it scales proportionally. This makes it impossible to tweak, and is now unusable. In 6.5 if I needed a thicker line I could dial it in. In 7.3 I need a thinner line and it is impossible.

This not only makes the outline feature effectively useless, but also seems to be passed on via the NormalThreshold setting (here at 100), which introduced spots and textures where they shouldn't be (the tip of the nose in this example).

Toon Shader Settings: Edge Width 1; Edge Intensity 80; NormalThreshold 100

I am enclosing 3 examples: 2K, 1K and 500 pixel with as identical settings as possible. Both are outlined with a 1 pixel (minimum) setting. The left was rendered in 7.3, the right in 6.5. Note: I am not concerned about the extraneous outline under the hair, simply the outline width, which is now unusable.

Note, I have mentioned this in the forum, and have opened a tech support ticket (146716). Sorry if this seems like I'm panicking, but I am -- this effectively makes the software useless to me.
OS: Windows 7
Attachment:
  • 2kComparison.jpg
  • 1kComparison.jpg
  • 500PixComparison.jpg
  •  5
  •  1364
Submitted bybexley
1
COMMENTS (5)
bexley
Three and a half years later and still NOTHING?????
bexley
TWO AND A HALF YEARS LATER AND YOU STILL HAVE NOT ADDRESSED THE PROBLEM!
bexley
... And another year and no action?!!!!  I love the way you guys are ready to blow the "game community" (WTTF that is) but don't give two s***s about the animators.  How hard is it to FIX THIS?  Just go back to 7.2!
donperion4000
This is a shame. If this wasnt a problem, this toon shader would be amazing.
bexley
...and it's been a YEAR and nothing done?
1