Put the render "Options" into a separate .mi file to make it more friendly for animation sequences
THE PURPOSE of this request is to make it easier to manage multi-frame (animation) Iray renders.
CURRENTLY the render "Options" which control things like Denoise and Maximum Samples (iterations) are written into each and every .mi file.
I SUGGEST the render Options should be written into ONE FILE which is then REFERENCED via a $include statement by the frame-specific .mi files.
WHY THIS MATTERS:
1) Supposed you export (Save MI File) a 600-frame animation sequence. That could easily take over an hour.
2) Then you realize you made a mistake, and had the wrong iteration limit, or you forgot to turn Denoise on.
3) Now you either need to edit 600 .mi files, or repeat the long export operation.
HOW MY SUGGESTION HELPS:
1) By having a single "Options" file, you could easily edit ONE file, and that would affect all 600 renders.
FILE NAMING CONVENTION:
Following the convention already used for the ".shader_decl.mi" file, I propose a ".options.mi" naming convention.
1) The "Options" section is the same as is currently used. It is simply written once to a different file.
2) This still retains the ability to "override" any settings on a frame-specific basis if necessary, as shown in my example, below.
3) I have tested this, and it works.
1) See the attached picture for an example of my proposed .mi file and the .options.mi file.
2) The example shows the ability to override settings that are in the .options.mi file.
This idea is also mentioned briefly in Issue #5383 submitted by user "4u2ges."https://www.reallusion.com/FeedBackTracker/Issue/Enable-Compositing-for-mi-Export-and-more