Votes
2
Product:
Character Creator 3
Version:
3.3
Status:
Assigned
Issue 7078
OBJ import on creating a new accessory has a strange Z offset
Im not sure if this is a bug, or its... me :) but anyway...

When I export a character as an OBJ (for prop and cloth modelling in Blender) I get a starange offset when i reimport the the mesh into CC3 again.

This is what I did:

1. Open a new project (the default woman appears in A-Pose)
2. Go to "Export --> OBJ --> Character With Current Pose"

This should export everything as it is into the OBJ ...

3. Create a new project in Blender 2.8, import the OBJ (see settings in screenshots) - it should import fine (feet on the floor, pivot at origin)
4. Select the object in Blender, "re export" it as an OBJ
5. in CC3 go to "Create --> Accessory" and select the OBJ created above for import

Now the newly imported mesh should perfectly overlay the mesh of the "standard female" but it has an offset in the negative Z axis...

This makes it very hard to precisely model props over CC3 characters in Blender (maybe in Maya too... i have no access to Maya atm... so not sure)
If I import the OBJ into Blender, its perfectly overlaying...

Im not 100% sure this is actually a bug at all... maybe i did something wrong, or Blender exported the OBJ in a way CC3 reads it in wrong...?

Maybe someone of the devs can have a look into it - just to make sure...

Otherwise ...

GREAT JOB ON THE NEW VERSION GUYS!
Really a pleasure and fun to use it...

Hopefully the little glitches get ironed out soon and we all can use this great tool without any bugs! :)

Have a great day!
OS: Windows 10
Attachment:
  • Accessory-Import-OBJ_1.jpg
  • Accessory-Import-OBJ_2.jpg
  • Accessory-Import-OBJ_3.jpg
  • Accessory-Import-OBJ_4.jpg
  •  6
  •  1036
Submitted byc68
1 2
COMMENTS (6)
will2power71
I created a video demonstration of what we're experiencing. This makes importing clothing for rigging very difficult. I've tried Maya, I've tried Cinema 4d and I've tried Nevercenter Silo --all with the same results.
will2power71
I've also had this problem which really turned me off to trying to make anything for CC3 models. This has been the issue since Character creator was first introduced. You export and re-import and everything is off.
klaudiuszw
I have the same problem! There are any solution?
c68
Thanks a lot, luke - that made the trick!! :)

I zeroed out the Pos and Rot and linked it to the Root   <--

Something that is strange tho is the fact (I found that out today by chance) that it works perfectly fine if I convert a character to the Game Base and THEN export and reimport ...
luke (RL)
Try to change the attach bone to BoneRoot with Pos and Rot selected
1 2