Votes
0
Product:
iClone 7
Version:
7.73
Status:
Released in 7.9
Issue 6803
IRay: Wrong depth, materialID channels for transparent objects during animation
When rendering animation with multiple channels (e.g. RGB + Depth + MaterialID),
the wrong bitmap channel is randomly rendered for transparent objects, e.g. hair and grass
For depth:
on Frame 1, the depth of the hair is correctly rendered in the depth map
on Frame 2, the depth for the hair is being rendered by a color channel
This happens randomly during rendering, but happens in all renders.

I've tried with a nVidia GTX960 and nVidia RTX2060 with the same result.

To recreate:
Create any character with long hair preset
Apply any animation
Render with iRay Standalone selecting Depth and MaterialID compositing channels
Observe channels are often rendered incorrectly

Attached are examples showing the hair from consecutive frames. Frame 2 shows the incorrect result.
OS: Windows 7
Attachment:
  • bathroom_Depth_00001.png
  • bathroom_Depth_00002.png
  • bathroom_Depth_00003.png
  • bathroom_Material ID_00001.png
  • bathroom_Material ID_00002.png
  • bathroom_Material ID_00003.png
  •  1
  •  853
Submitted byJohnLiebe
1
COMMENTS (1)
Feedback Tracker Admin
Hi JohnRLee,

Thank you for providing the information. We have reproduced this problem in Iray v1.3 and fixed this issue in the latest internal version. Please wait for the release of Iray v1.4 and try again to see if it still happens. Please let us know the result. Thank you so much.


Soya
Reallusion
Attachment:
  • 1.jpg
  • 2.jpg
  • 3.jpg
1