Votes
0
Product:
iClone 7
Version:
7.2
Status:
Released in 7.3
Issue 3808
FKmode menu doesn't show up when clicking on CurveEditor
If I select a character I can bring up the Edit Motion Layer (either by "N" shortcut or from the Modify>Motion menu) and it works normally, however when I try to edit the motion with the Curve Editor the "FK mode" button doesn't work.
If the EditMotionLayer menu is active when I open the Curve Editor, pressing "FK mode" closes the EditMotionLayer menu, but it fails to open it. This is a problem, as I can't select the bones through a visual menu and I have to spend a lot of time scrolling the bones list to find the right one everytime.

Please help! <3
OS: Windows 10
  •  4
  •  1908
Submitted byMatt GH
1
COMMENTS (4)
Matt GH
As I said in the previous comment, I had to roll back to 7.1 to fix another problem (FeedBack Tracker issue #3790) so I can't provide a screenshot.

Anyway, there is nothing to screenshot. Just a button that doesn't work, according to the description.
I tried to give you all the possible info to help you detect the problem, along with all the elements to try to reproduce the issue and/or locate the corresponding code section responsible for the weird behaviour.



I try to explain it again:
1) select a motion clip on a standard character
2) sample all parts
3) open Curve Editor
4) click on FK MODE
- in 7.1 it works, in 7.2 it doesn't.

It seems to me that pressing the FK MODE button should work indicatively like this:
   when(buttonpressed) then
      disable(cameralook, linkbutton);
      opentab(FKmode);
   end;

So I guess the problem is either on opening the tab OR visualizing it in the proper area (maybe the tab DOES open, but it's pushed outside visible space so it can't be interacted with).

I really hope I have given you enough info to investigate the problem, for a screenshot would be both impossible to obtain and redundant.

Thank you in advance, and keep up the good work!
Feedback Tracker Admin
Thank you for your feedback.

Please capture a screen shot and attach it in your next comment.

Your help is highly appreciated.

Reallusion
Matt GH
UPDATE: On 7.2 if I click on FKmode while on curve editor the "camera" and "link" button on the top tray get disabled (as they should be while the EditMotionLayer window is shown). If I click on it again the buttons get enabled again.

UPDATE 2: I tried rolling back to 7.1 to fix another problem (FeedBack Tracker issue #3790) and now everything works fine. It may be something related with 7.2 alone, since previous patch doesn't have the same bug.
Matt GH
I tried uninstalling iClone, rebooting the system and install a clean version of 7.2, but the issue still persists.
1