Votes
0
Product:
Character Creator 4
Version:
4.21
Status:
Released in 4.3
Issue 9383
Can't add displacement maps to CC3+ characters in 4.2/4.21
I tried to load 4.11 created CC3+ character files on 4.2, but it always crashed. Then I set up my character from scratch (using GoZ and custom textures) in 4.2 and it crashed again when I added displacement maps to the body. Tried again after the 4.21 update, but it still crashes when adding displacement maps (black and white).

I'm stuck using 4.11 until this is fixed because character expressions are significantly different with displacement maps applied to the models (especially around the mouth).
OS: Windows 10
  •  4
  •  1142
Submitted byHoben
1
COMMENTS (4)
WayN
Hi Hoben, 

Are you using .exr image as a gray-scale or vector displacement map?

Weien,
Reallusion
Hoben
Hi, Calvin.

I'm not at a liberty to share said files, so I've done some more troubleshooting.

Looks like only EXR displacement maps won't load in 4.21 projects (32 bit ones at least).  I deleted those from my 4.11 projects and they still wouldn't load in 4.21, though.  After baking morphs, two of my 4.11 projects finally opened in 4.21, then I just added 16bit PNGs and adjusted the Gray-scale Base Value under Tessellation in the Material settings to get back to the same look.  However, the last one I need to work on still wouldn't open, so I just recreated it with GoZ.  The only thing different about that one is that I swapped out a texture in the cornea shader and tweaked some of the corresponding settings, but I don't have the time to check out if that's really at fault.

So yeah... EXR displacement maps no longer work and people should be encouraged to bake their morph adjustments before updating.

Cheers!
Feedback Tracker Admin
Hi Hoben,

Thanks for your feedback!
Currently, we can't reproduce the issue in our end, please send your project and 4K texture to us.
You can upload to cloud service such as Google Drive, and attach the download link in your next comment.
You can also set the comment as private.
Thanks for your help!

Calvin
Reallusion
Hoben
I'm using all 4K textures on my characters, but I tried downscaling some of the displacement maps to 2K and they worked.   Then I tried swapping them out for the 4K ones, but that still crashes CC4.

But the problem with 2K displacement maps is that the effect is not the same as with 4K.  It's not just a lack of detail... it pushes out way more topology than the otherwise identical 4K ones.

Please restore the functionality of 4K.  It was working beautifully before 4.2.

Thanks!
1