Votes
0
Product:
Character Creator 4
Version:
4.12
Status:
Fix In Review
Issue 9276
Bug in textures path
Hello,

The hotfix provided for texture path bug in content manager ( https://drive.google.com/file/d/1ycijcRRYAU71CxFyxebezV1bCyFBruFH/view?usp=share_link ) does not work for me.

I have not anything special on my computer (PC / Win10 x64), the computer is on a AD domain and I am admin on this PC.

The hotfix seem to be install correctly but fix nothing (I run it from admin command prompt).

On second screenshot content manager show a path that does not exist on my computer. I do not have D: drive.

Please help me, this bug is very anoying.

Thank.
OS: Windows 10
Attachment:
  • Snap 2023-01-30 at 16.37.48.png
  • Snap 2023-01-30 at 16.48.51.png
  •  3
  •  1205
Submitted byCLARTE
1
COMMENTS (3)
CLARTE
Thank for your help.The reset metadata thing seem to be worked. Error message at character load no longer happen.
Just in case, for investigate on this bug I let you the CMS folder extract from my workstation : https://filemanager.clarte.asso.fr/index.php/s/jyFr7HzGBbQzSRY
Feedback Tracker Admin
Hi CLARTE

It's good to hear the issue has been resolved.
We will check the file you provided.

Thanks for your help, please feel free to contact us if any.
Tina
CLARTE
Thank for your help. Unfortunatly the steps provided did not work.

1- The folder \Reallusion Templates\Others\Skin Textures exist and contain assets

I uninstalled character pack and skin makup but when I reinstall it there is missing character. Neutral_M is missing and fail to reinstall. The legacy version is also affected too. (look at "A" on process.jpg image).

Bug in textures paths is still present.

Some others tests :

With the character "neutral female". The character loads well but when I enable editor the texture path bug occurs.
- On process.jpg image (B) I uninstalled Skin & Makup --> load "neutral female" --> enabling editor == texture path bug. However missing textures on character is normal.
- On process.jpg image (C) Skin & Makup pack installed --> load "neutral female" --> enabling editor == texture path bug again. Here, there is no missing texture, but the bug still present.

Before uninstall/reinstall character pack the texture path bug occurs just after character load.

After steps you given here (uninstall/reinstall character pack) the texture path bug do not occurs afters loading character but is still present when I enable editor. Strange thing, there is no display issue and textures files are in the right folders. For example "position" and ws_normal are indicated as missing while they are actually present in folder. (look at texture_missing and but_exist)

When I try to reasign textures it works but the bug comme back when I close the character and reopen it. Auto search is useless since textures files have the same name for diferents characters.

I am lost and tis bug block my work. I already uninstall and reinstalled several time the soft and the texture ath bug still prensent each time. I have admin rights on my machine. This bug occurs since the last update, before that it was working well.
Attachment:
  • process.jpg
  • character_content_infos.png
  • version_product.png
  • texture_missing.png
  • but_exist.png
Feedback Tracker Admin
Hi CLARTE

Thanks for your testing.
Recording to your description, I'm not sure if there's some database problem of CC.
Could you try these steps?
(1) Go to folder:
C:\ProgramData\Reallusion
(2) Copy "CMS" folder and past it to other path
(3) Compress the copied "CMS" folder
(4) Send us the file
(5) Open CC
(6) Go to Content panel
(7) Right click on Refresh button
(8) Click Reset MetaData (ref: attached image)
(9) Wait for the process to complete
(10) Check character and its texture again

Sending file to us is the way we can see if the data is correct, and reset metadata will let application to recognize the content path again.
If the method could fix your problem, please let us know.
If the problem persists, please let us know as well, we will see how to fix it in next step.

Thanks for your patient.
Tina
Attachment:
  • Reset MetaData.png
Feedback Tracker Admin
Hi CLARTE 

Thanks for your feedback.
Unfortunately, we'es unable to reproduce the issue in our environment, please follow the steps below to fix the problem:
(1) Go to folder where you install the content, and find the subfolder (ref: attached image)
\Reallusion Templates\Others\Skin Textures
(2) If there's no same folder or textures in it, please open CC and go to Content Manager.
(3) Go to "Pack" tab and find "Free Resource" category.
(4) Install "Characters" and "Skin & Makeup" pack. (If the pack had installed already, please uninstall then install it again)
(5) Load character and activate SkinGen to check if problem still happen.

If in step (2) there's correct folders and textures but still missing texture, please save the ccProject and upload it to any cloud drive (like Google drive) and provide us download link, you can set private comment by ticking checkbox if you want.

Thanks for your patient, please feel free to contact us if any.
Tina
Attachment:
  • texture_path.jpg
1